Thursday, September 13, 2012

Kinect and OpenNI Support

It's been my nightmare trying to figure out why the Kinect wasn't working properly with the OpenNI. The frames just get corrupted from time to time, and eventually 'segmentation fault'...



/DEBUG   (  104): stack:I/DEBUG   (  104):     6079dd38  5d275c8b  /system/lib/libXnDeviceSensorV2.soI/DEBUG   (  104):     6079dd3c  5d2ece84  /system/lib/libXnDeviceSensorV2.soI/DEBUG   (  104):     6079dd40  01f429fc  [heap]I/DEBUG   (  104):     6079dd44  000000f0  I/DEBUG   (  104):     6079dd48  6079dd64  I/DEBUG   (  104):     6079dd4c  fffffd81  I/DEBUG   (  104):     6079dd50  fffffd82  I/DEBUG   (  104):     6079dd54  0000027f  I/DEBUG   (  104):     6079dd58  00003c7e  I/DEBUG   (  104):     6079dd5c  00000000  I/DEBUG   (  104):     6079dd60  00000786  I/DEBUG   (  104):     6079dd64  000000f0  I/DEBUG   (  104):     6079dd68  00000000  I/DEBUG   (  104):     6079dd6c  01f42948  [heap]I/DEBUG   (  104):     6079dd70  df0027ad  I/DEBUG   (  104):     6079dd74  00000000  I/DEBUG   (  104): #00 6079dd78  01f42948  [heap]I/DEBUG   (  104):     6079dd7c  00000774  I/DEBUG   (  104):     6079dd80  01ee1efc  [heap]I/DEBUG   (  104):     6079dd84  01ee1efc  [heap]I/DEBUG   (  104):     6079dd88  00000774  I/DEBUG   (  104):     6079dd8c  5d2ebd94  /system/lib/libXnDeviceSensorV2.soI/DEBUG   (  104):     6079dd90  5d2ec620  /system/lib/libXnDeviceSensorV2.soI/DEBUG   (  104):     6079dd94  60971ee4  I/DEBUG   (  104):     6079dd98  01f42a94  [heap]I/DEBUG   (  104):     6079dd9c  5b1bfd17  /system/lib/libOpenNI.soI/DEBUG   (  104): #01 6079dda0  01f42a94  [heap]I/DEBUG   (  104):     6079dda4  5d2999b1  /system/lib/libXnDeviceSensorV2.so
Fortunately, I've confirmed that OpenNI works perfectly fine on an ASUS Xtion Live.

HOWEVER, today!, I still don't have the ASUS Xtion with me... !! Guys, donations? 

No comments:

Post a Comment